IDEとAHCI比較(Win7)


X61でVertex 120GBのベンチスコアがいまいちなのは
SATAドライバが原因ではないかと思い測定してみました。

その前に初期のVertexはAHCIでは認識できなかったため
IDEでWindows7をインストールしたわけですが
ファームウェア1275ではAHCIでも使えるようになってました。
1199のときは試してなかったのでわかりません。

ですが、すでにIDEでインストールしてしまってるので、ちょっと儀式が必要でした。

HLM\SYSTEM\CurrentControlSet\Services\msahci
Start の値を3 > 0 に変更して電源を切る
BIOSでAHCIに変更して起動
AHCIドライバインストール後、再起動

無事にAHCIへ移行できました。
そのあとIntel AHCIドライバをインストールして完了です。

IDEモード
IDEのまま

AHCIモード Win7標準ドライバ6.1.7000.0
AHCI Ver.6.1.7000.0(Windows 7 標準ドライバ)

AHCIモード Intelドライバ 8.8.0.1009
AHCI Ver.8.8.0.1009(Intel ドライバ)

IDEからAHCIでは微妙にライトがアップしてますが
ドライバではあまり差が出ませんでした。
というか4kがダウンしてます。
もう、劣化かよ・・・

Trim対応のファームが出たみたいですが
Windows7ベータじゃTrim対応していないので意味ないよなー

追記: 2009年6月23日
Thinkpad X61がSATAII接続でないのでは
というコメントを見ていろいろ調べてみました。

デバイスマネージャを確認してみましてみると
IDE ATA/ATAPI コントローラには次の三つがありましたが
どれをみても、SATAIIで動作しているかどうかは確認できませんでした。

・ ATA Channel 0
・ Intel(R) ICH8M Ultra ATA Storage Controllers - 2850
・ Intel(R) ICH8M-E/M SATA AHCI Controller

次に思いついたのはHD TuneのInfoです。
HD Tune Info
Supported: UDMA Mode 6 (Ultra ATA/133)
Active: UDMA Mode 7 (Ultra ATA/512)

UDMA Mode 7がアクティブみたいですが、この規格の詳細が不明です。
Ultra ATA/512となっているので512MB/sということでしょうか。
SATAIIは375MB/sですのでHD Tuneがおかしいのかもしれません。

X61のサウスブリッジ ICH8MはSATA 3.0Gbps対応していますが
LenovoのフォーラムによるとX61はSATAIIドライブは使えるが
1.5Gbpsの速度しか出ないそうです。つまりSATA接続なのでしょうか?
修正してくれとの書き込みも見られました。

なにやらCentrino2からようやく3.0Gbps対応するそうで
X200sはすでに対応しているとのことです。

なるほど・・・ゴクリ

ソース:その1その2


“IDEとAHCI比較(Win7)” への4件の返信

  1. 私のX61TではIntel® Matrix Storage Managerだと現在のシリアルATA転送モード 生成1と出ますよ。
    VTX60から120に変えてみて速度がほとんど変わってなかったのでもしやと思い気がつきましたが120はそのままデスクトップへ。
    いづれにしてもさっぱり残念です。

コメントを残す